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特定の電子証明書で署名できない、またセキュリティーが設定されたDocuWorks文書を開けない

登録日:2026年4月10日
最終更新日:2026年4月10日

対象環境

DocuWorks 9.1

現象

対応していない電子証明書を利用した場合、下記2つの現象が双方発生します。

  • 特定の電子証明書を使用してDocuWorks文書に署名しようとすると、署名して保存時に「秘密鍵にアクセスできません。」が表示され署名できない。
  • 特定の電子証明書を使用してセキュリティーが設定されたDocuWorks文書を開く際、「秘密鍵にアクセスできないためこの文書を開くことができません。電子証明書によるセキュリティーで保護されています。」が表示され開くことができない。
原因

「現象」に記載の通り、DocuWorks 9.1では特定の電子証明書に対応していないため、該当する電子証明書を利用した署名や、セキュリティー保護されたDocuWorks文書のセキュリティー解除および閲覧が正常に行えない場合があります。

対処方法

コマンドプロンプトを起動し、「certutil -user -store My」を入力して実行すると各電子証明書の情報がリスト表示されますので、該当する電子証明書の「プロバイダー」をご確認ください。「プロバイダー」が以下のものに該当する場合、DocuWorksは未対応となるため、ご利用をお控えください。

- Microsoft Software Key Storage Provider
- Microsoft Smart Card Key Storage Provider

DocuWorksが未対応の電子証明書を使ってDocuWorks文書のセキュリティー設定を行った場合、その後の解除ができないことがあります。新しい電子証明書をご利用になる際は、必ず文書データのバックアップを作成してからご利用ください。